Allocate: What version of Windows do I need?

Allocate requires Windows 7 and above to work properly. If you are trying to run it in a lower Windows version, you may run into issues. 

Powered by Zendesk